Singapore Flyer

Monday, February 26, 2018

Error: Package: php-gd-5.4.45-13.el6.remi.x86_64 (remi)

Error : Package: php-gd-5.4.45-13.el6.remi.x86_64 (remi)

The error happen after I upgraded PHP from 5.3 to 5.6. Then when i tried to install php-gd I am seeing this error.

Solution:

yum --enablerepo=remi,remi-php56 install php-gd

The above end up in another error:

Error: Package: gd-last-2.2.5-1.el6.remi.x86_64 (remi)
Request: libwebp.so.5 () (64bit)



Solution:

It seems that you are requesting libwebp, so just install libwebp from epel

If you have not installed epel yet,


yum install epel-release -y
yum update

Install libwebp


yum install libwebp --enablerepo=epel -y

Install php-gd


yum install php-gd  --enableablepo=remi 

It will works!


 

No comments:

Post a Comment